Cannot scan or send e-mail with Fairphone 4

I tried and failed to scan, so I tried to send an e-mail, but no target address appeared in my draft, using the T-Online mail app, and I could not find your e-mail address anywhere else.

Those was the content of the mail:

I am not sure what is meant to happen, but when I tap Scan (at the bottom of the screen) in the app and then point the camera at a bar code, nothing visible happens. I have tried then tapping various things, but not found anything that helps. Scanning the same item with “QR and barcode scanner” works. (The camera app does not automatically scan.)

OS: Android (SDK Int: 31 / Release: 12)
Model: FP4
Product: FP4eea
Device: FP4
App version:4.9.2
App build number:1238
App package name:org.openfoodfacts.scanner

I also thought these screenshots relevant:

(Not allowed to post them all in the same post)

The attached log had this content:

I 2023-10-10 12:05:04 SmoothService:New app session started
D 2023-10-10 12:10:23 PermissionListener:New permission value: DevicePermission{permission:, status: DevicePermissionStatus.unknown}
D 2023-10-10 12:10:34 PermissionListener:New permission value: DevicePermission{permission:, status: DevicePermissionStatus.granted}

Next screenshot:



N.B. Pointing straighter at the code makes no difference.


Thanks for your report.
Just to identify the root cause of the issue, did you install the app through the Google Play or FDroid (we use different scan solutions).

Is the problem still reproducible after closing/restarting the app?

I feel sure it must have been Google Play, as FDroid means nothing to me!

I have just retried, and had a satisfactory result, attached.

I the meantime I have had an update from Android 12 to 13. I cannot remember if I tried restarting the app.

Hope this helps!

Scanning now happens automatically, without tapping “Scan”.