Impossible to edit the nutrition information of some products

There are a number of products with obviously incorrect nutrition information that I tried fixing multiple times but, whether I use the Android App or the website, my edits are being ignored.

For instance:

The page says 9 kj but 87 kcal which is inconsistent. It even says so on the page.
Yet I fixed the nutrition information about 6 times. Each of my edit is visible in the history and yet the nutrition information never changed :frowning:
What am I missing?

Also, is there a way to see what a given edit changed in diff format?

Hello! I managed to modify the energy in kj to the correct value (from the photo).

About the diff, I would forward this to @stephane or @alex.

Cool. How did you do it?

Also, unfortunately the photo was a bit out of date. More precisely the photo I uploaded was there but, presumably because the whole update failed, it was not selected as the nutritional information photo. (also it would be nice to have the date of each photo)

And I still cannot change anything in the nutrition table. I tried changing each of the individual information below:

  • I cannot change 370 kj / 87 kcal to 329 kj / 78 kcal. I thought this could maybe be because of rounding: 329 kj = 78.6 kcal and 78 kcal = 326.3 kj. But neither combination works.
  • I cannot set the saturated fat to 0.2 g.
  • I cannot change the proteins from 20 g to 18 g.
  • And I cannot even change the salt from 0.25 to 0.24 g.

But at least now the product page shows the right photo for the nutrition information.

I really just clicked on “Edit product” and then entered the right info.

Could you tell how did you edit the product? From the website, the app, the api, etc…

@fgouget are you using F-Droid version of the application ?

We are really sorry but it’s an old version because publication is still blocked by a technical issue, see Draft: Update openfoodfacts to new app version (!13045) · Merge requests · F-Droid / Data · GitLab

I discovered the new version of the Android app earlier this week but I have indeed mostly been using the F-Droid version.

However for all the products that are causing trouble I also tried editing through the website. In particular the attempts I mentioned above were all done through the website. But to no avail :frowning:

That’s really strange!

We should really implement a diff view though :smile:

I gave it another round of tries:

  1. F-Droid updated their OpenFoodFacts application to 4.8.0. So I tried that but it just freezes on startup on my Galaxy S7 (SM-G930F, Android 8.0.0).
  2. I also tried the application from the Play Store (4.7.0) and this one appears to be functional, except that as with the old application, after I modify and save the nutritional information nothing is saved.
  3. I tried making the update on my desktop by going to www.openfoodfacts.org in Firefox (114.0.2, Linux). But again all I get is a new entry in the changelog but no actual change to the product information.
  4. Then I tried in Chromium (113.0.5672.126, Linux) to no avail.
  5. Then I tried in a new account but that made no difference.
  6. And now I don´t even have the quantity fields on the website: I have “Énergie (kcal) kcal” but no place to enter the amount of calories.

So as far as I can tell OpenFoodFacts is unusable. I don´t see why I would be the only one being impacted given that this issue has been going on for weeks (I’ve had trouble for months but I used to be able to work around the app issue by using the website), across multiple versions (3) and multiple platforms (3). This gives me the impression that OpenFoodFacts no longer cares about user input.

No I scan’t!

I don’t think that a technical issue like this can be generalized to that though… Remember that the project is run mostly by volunteers, so consider this while using the service.

Would you mind reporting the issue on GitHub - openfoodfacts/smooth-app: The new Open Food Facts mobile application for Android and iOS, crafted with Flutter and Dart? That way app developers can troubleshoot it and fix it for everyone.

So this is the issue we were talking about before. I’m going to open an issue on github and tag you, so that devs can help you better.

Could you try using the world.openfoodfacts.org version of the website (same credentials, just different language) to see if it’s reproducible?

Edit: Created the issue (User is not able to edit products from the web interface · Issue #8644 · openfoodfacts/openfoodfacts-server · GitHub)

Thanks for reporting the issue through the right GitHub channel. I added the result of the test with world.openfoodfacts.org there (still no luck) and all the other details that seemed like they may be relevant.

Should this issue still be reported to the GitHub smooth app given that it happens with the website too? It does seem more likely to be a backend issue (unless there is code that’s shared between the web, new and old Android clients).

Yup, I agree, so let’s wait for now